PDA

View Full Version : I can't stop it!!!



BorG
06-10-2000, 09:17 PM
Guys, I was using my T-maxx today and I noticed that the brakes were not stopping the truck as quickly. I have no idea what's wrong. The T-maxx used to stop instantly when I apply the brakes, but now, it is much slower. The brakes seem to be in perfect condition, with little wear and tear. Any help would be appreciated.

------------------
If you can't see my tail light, then you're ahead of me. :)

KITT
06-10-2000, 10:55 PM
BorG, as you know I don't have a T-maxx (YET, i plan on getting one a.s.a.p.) but your servo(s) maybe "out of whack" try the trim adjuster on the TQ radio. my friend has a nitro with a fiberous disc brake and he had to re-adjust the servo after he broke it in.

------------------
http://karrnet.freeservers.com/Karr1.gif

80's
monster trucks
girls

dlwill1@pacbell.net

joe
02-25-2001, 08:07 AM
low batt?

also use sand paper to roughen up the braking surfaces

grandmasterofpool
02-25-2001, 11:29 AM
Check and see if your brakes are gathering fuel residue. If so then make a little shield out of some scrap lexan or a 2 liter soda bottle.

pp13b
02-25-2001, 07:08 PM
u might need a better throttle/brake servo to pull it up better..?

XXXER
02-25-2001, 10:43 PM
Check the hex, it for some wierd reason could be stripped.

BobHastings
03-01-2001, 01:09 PM
Borg,

You use brakes? I didn't receive the memo.

Spring is coming dude!

Ulti Maxxer
03-03-2001, 03:50 PM
maybe, you just wore the disk down a little and its taking longer to bite. try the trim.