Notices
 

Thread: Kyosho Blizzard/Heavy Metal

Page 1 of 10 12345678910 LastLast
Results 1 to 25 of 242
  1. Kyosho Blizzard/Heavy Metal 
    #1
    Join Date
    04-07-2000
    Location
    Lake Forest, CA
    Posts
    6,151
    Thread started at the request of Blaneo
     

  2.  
    #2
    Join Date
    07-18-2002
    Location
    Halifax, NS, Canada
    Posts
    158
    We even got an Elecric forum. Sweet....

    RallyRoach
     

  3. The Project Continues 
    #3
    Join Date
    07-18-2002
    Location
    Halifax, NS, Canada
    Posts
    158
    Okay, in the intrest of talking to myself again, here's the updates on my Heavy Metal Project.

    I continue to mess with the front axle, but the trans seems to be holding together nicely. I ordered a set of 4-40 tap/die from Great Hobbies which should get here next week, so I'll hopefully have a fully functioning unit for the weekend. I also have a Bolink Little Red Wagon body on order. I think it will fit, but if not, I'll just do a little creative mounting.

    On the down side, 2 of the soldered connections let go while I was out and about on the weekend. I'm thinking of replacing all of the wires between the MSC and the motors with something a bit better, but since I've only got 380s, its a little overkill to use the 18 ga RC wire I has sitting around... or not... I'l see how ambitous I feel...

    Also, I finally have some pix:


    That's a full on shot, I really like the look of this thing




    And that's the guts, in case anyone with a new-age Blizzard is wondering what us classic fanatics have to deal with.

    Anyway
    Last edited by RallyRoach; 02-22-2003 at 08:11 PM.
     

  4.  
    #4
    Hey I found your pictures. Good looking vehicle. I notice in the pictures, that your tracks seem to me, to be a bit loose. I keep mine tighter then that. Say, would you be interested in adding your vehicle to my webpage. You can see at the following address.
    http://community.webtv.net/monsters4...rucksandStuff/
     

  5.  
    #5
    Join Date
    07-18-2002
    Location
    Halifax, NS, Canada
    Posts
    158
    Sure, if you want to have my Blizz' on your site, its fine by me. These are the only pix I've got so far, but I'm sure to have lots more... Lemme know if you need a write up or anything.

    RallyRoach
     

  6.  
    #6
    Hey, guess what I bought this weekend. Yep, I got an electric version of the Blizzard. Hopefully it will be here by the weekend. So now you have some company on this thread. Did you ever get the Bolink Body? I was wondering how well it fit the chassis. Have you updated the motors to bigger ones?
     

  7.  
    #7
    Join Date
    07-18-2002
    Location
    Halifax, NS, Canada
    Posts
    158
    Sweet, did you get one of the oldies like mine, or the EP version?

    And no, I never did get the Bolink body, too much red tape trying to get it past the border right now Ditto for the motors I wanted... maybe once everyone's had the gun off for a bit, things will open up. Oh well, at least we're not hearing updates every 5 minutes on what some has-been- celebrity murderer had for breakfast eh?

    But I degress...

    RallyRoach
     

  8.  
    #8
    I havn't gotten it yet, but I believe it is an EP version. I know what you mean about getting things across the border. I have been waiting for over three weeks for a sega dreamcast system that I bought from a fella. Shipping to a business address seems to help, but even that is slow. First things I figure I'll do with it are play around with the motors and the speed controls. Thinking towards a couple of electronic speed controls. Then seeing just how far I can go with the motors. I was really hoping that you had gotten that body, I am curious as to how it will fit the chassis. I would like to get something different for my nitro. I am hoping that the electric will do better on ground then the nitro. My nitro is a dog on the ground. Hey get this, I was bidding on another EP Blizzard on eBay. The bidding started going crazy all of a sudden, and ended up finishing out at $350 plus shipping. I quit at $330. The day after it ended the owner contacts me and asks me if I would be interested in it, cause the other guy is acting "really weird". I told him that I might be, but I wanted to think about it because I thought it was unfair that I should have to pay what I bid, which was in relation to what the other guy falsely bid. He wrote me back and told me I was getting one heck of a deal, and that it should have gone for $650. I wrote him back and asked him where he got his information. I think $300 is too much for one of these, unless it is brand new in the box and comes with a bunch of goodies. What do you think? Gotta go, talk with ya later.
     

  9.  
    #9
    Join Date
    07-18-2002
    Location
    Halifax, NS, Canada
    Posts
    158
    Hmm, I don't know how much of a difference you're going to find on ground if you got an EP. They have the same disc-brake steering system as the nitro versions. I've heard it does work better just because you get rid of all the oil and goop associated with a nitro engine, but you'll still have the same fade problems if the discs get wet.

    I'm still planning on geting the body, its just going to take while. I'll have to order directly from Bolink , so the extra cost is going to be considerable.

    As for esc, well, in the EP's case, you can get off easy because all you need is the one esc. As for me, I'm still working on a contingency plan for when my MSC nurns out. I'm still not quite figured out how to do it, but I think I may grab 2 old losi wiper speed controls from my LHS. They're old, but I think they can be adapted if needed. We shall see...

    And on the subject of motors, I'm still debating wheter to try running a set of 540's in my Blizz. I think the drivetrain can handle it, but the last thing I want to do is strip off a gear that hasn't been made in 15 years

    Anyway, just my $0.02...

    RallyRoach
     

  10.  
    #10
    Good points to ponder there. I did get the Blizzard yesterday, but I havn't checked it out yet, other then making sure it arrived okay. This weekend I hope to get out and run it, just to see what it will do. I really plan to use it in the winter, but we'll see what happens in the dirt and grass. I think these would have better control plowing then a Nitro Blizzard.
     

  11.  
    #11
    Well make that 3 of us here now, well hopefully if you guys haven't run off. But I picked myself up a Heavy Metal and have already stripped started on the slow rebuild. Picked up a brand new set of wheels for it, replacing all the bushings with bearings. It came with a set of hop-up motors but they are so run down and aren't rebuild so I can't cut the comm. so I've seen on Towers they still sell the right sized motors and actually have some modified motors that I might pick up rather then going the 540 route. But here's a few pics.





    Last edited by mavrick0; 06-07-2003 at 10:27 AM.
     

  12.  
    #12
    Hi mavrickO:
    LOL yours looks lik my nitro blizzard, only mine is in a storage container. My EP Blizzard is sitting on the workbench untouched also. Looks as though you have a real good starting vehicle though. We (I and RallyRoach) will be here for ya. Keep writing, maybe it will get the two of us off our duffs and get ours out and moving again.
     

  13.  
    #13
    Join Date
    07-18-2002
    Location
    Halifax, NS, Canada
    Posts
    158
    I've completely gone through my Heavy Metal now, and I "think" I have most of the bugs ironed out. though I really appreciate those pics of the trans in pieces. I suspected I had some siezed parts in mine, and now I'm sure In mine, one of the idler gearsets has frozen to its shaft, making life difficult. I've got it working reliably, but there's still a bit of drag in that side of the trans. Now I know why...

    Anyway, if you need any help, or reference to a complete HMBlizz, let me know and I'll post what I can.

    RallyRoach

    PS- once you get the trans back together, I highly reccomend greasing it up with Plastic safe grease. I got mine from a bike shop (they use in in their shifter mechanisms). Great stuff, really smoothes out the trans, especially if yours is as wrn as mine is

    In the same vien, put dielectric grease on the entiore speed control (thin coat only tho, no gooping). I did mine once and after a winter of running through snow and slush, no corrosion
     

  14.  
    #14
    Thanx guys I will definitely will be back if I have any questions. I got lucky enough from a guy on eBay that was selling one that I asked if he had a manual and could copy it for me for a couple of bucks. Well he actually had a second copy of the manual so I have that coming which will help out a lot in the rebuilding.

    But I need to look into getting a new tub chassis for it and with the manual figure out the front suspension since the left and right didn't match eachother or match the rest of the suspension arms on the other 8 bogies. I already have a brand new set of chrome wheels for it minus the drive wheels so the originals are probably going to get dyed some funky colour to match whatever body I decide to get for it. But I'll keep you all updated and like you said maybe inspire you guys to get yours built up again too. Just wish this board would support my pic host so I don't have to keep using montypics.
     

  15.  
    #15
    Well I finnally got it done. Well almost done anyway. Runs pretty good, actually better then the Nitro Blizzard in the grass. It has the stock motors, but I am already thinking of upgrading to bigger ones. I have a couple of 22T motors I am thinking about starting with, and seeing what happens. Strobe light works now and the foglights soon will. Futaba T3PDF 3 Channel Radio helps with the driving and plow controls. I got lazy when it came to masking off the windows and now I am hating it. Looks like crap. I am gonna have to try to get that paint off of them without scratching them. LOL yeah right
     

  16.  
    #16
    Well I finnally got it done. Well almost done anyway. Runs pretty good, actually better then the Nitro Blizzard in the grass. It has the stock motors, but I am already thinking of upgrading to bigger ones. I have a couple of 22T motors I am thinking about starting with, and seeing what happens. Strobe light works now and the foglights soon will. Futaba T3PDF 3 Channel Radio helps with the driving and plow controls. I got lazy when it came to masking off the windows and now I am hating it. Looks like crap. I am gonna have to try to get that paint off of them without scratching them. LOL yeah right
     

  17.  
    #17
    Hopefully one of the administrators will catch that second posting and delete it. I hate wasting space like that. Sorry. Here's a second picture of both my models.
     

  18.  
    #18
    Hey what happened with mavrick O pictures? Does the Heavy Metal have 540 motors in it? My DX has 380 motors in it.
     

  19.  
    #19
    Join Date
    07-18-2002
    Location
    Halifax, NS, Canada
    Posts
    158
    Blaneo: Cool plow man! And no, the HM only has 380s as well, but with things this old, who knows what's been done to them by the time we get them right?

    Well, I've decided to sell off my Heavy Metal. I've decided to start e-buggy racing after learning for 2 years in e-trucks, so I need to clean out a few of the toys. I got a nice Losi XXCR lined up as soon as I can raise the funds

    Anyway, I'll be posting a link in the eBay section of this site in the next 2 days. Good luck with all your projects everyone!!

    RallyRoach
     

  20.  
    #20
    The pics aren't working cause they were on montypics and now that you need to pay I deleted my account.

    I would edit the post but they have a dumb set up here for that so if you want me to put pics up again I can do that.

    But if any of you guys have a new chassis for the DX/Heavy metal I need one badly. That's all I'm looking for for mine now. And the one I have it totally garbage.
     

  21.  
    #21
    RallyRoach:
    Well...I will hate to see you go.I hope you have good luck and sucess with the trucks.

    MavrickO:
    No problem with the pics, I just couldn't figure why some of them were missing. Hey why don't you and RallyRoach hook up and make a deal for his HeavyMetal? It would save you both a lot of time and hassles.
     

  22. You guys still around 
    #22
    Join Date
    04-14-2002
    Location
    Upstate NY
    Posts
    113
    You guys still on the boards I have a new blizzard that I have been trying to get together. I say new I got it used and put new everything in it I got ripped in a trade but thats life. I have put full bearings in it and a new body. The problem I am having is getting the body mounted. I have drawn up a plan to make a half track I have a extra monster truck front end set that runs on a drive shaft. I have been trying to figure out how to run a drive shaft from the motor on the blizzard to the front wheels. Anyway maybe you guys are around and can give me some ideas.
    Thanks
    Frank
     

  23.  
    #23
    Join Date
    07-18-2002
    Location
    Halifax, NS, Canada
    Posts
    158
    If you're trying to make a front drive/track vehicle, I'd say the easiest thing would be to get a seperate front drive system. Something like a Clod front axle, or the drivetrain from a Stampede mounted up front. As long as you kept the skid-steer system on the Blizzard chassis, you wouldn't even need to make the front axle steer. Wire the motors up like a clod, and boom, full-driven 1/2-track. Just my $0.02

    RallyRoach
     

  24.  
    #24
    RallyRoach:
    Whats up? How you been doing? You got rid your Heavy Metal didn't you? Atleast I thought I was bidding on yours. LOL

    lakeside_Hobbie:
    Hi Frank, did you get my email? I concur with Rally about the front drive. But,I was thinking more along the lines of Kyosho, keeping it all in the family (so to speak). Using a USA-1 or Double Dare gearbox would be an easy setup. I was thinking about it and figured that would be the easy thing to do. The only problem would be to get the two drive systems geared the same. Sunday it dawned on me that I have a Parma Pulling Truck body that would be perfect for just such an application. It would even mount directly to the Blizzard deck and it looks like the front wheels would line up with the front wheel wheels of the pulling body. Just a thought.

    Talk with ya all later.
     

  25. Cool 
    #25
    Join Date
    04-14-2002
    Location
    Upstate NY
    Posts
    113
    Yeah I thought about the usa 1 myself and than a dual esc for both motors. But as you said gearing would be a problem, but the usa 1 is much better than trying to run a drive shaft. On a side note do any of you guys have front pulley wheels or know where to get them for the origional ep blizzard I have one sitting in a box just missing those parts. Or maybe i will sell it for parts. Also I have a new e/p blizzard and i need a manual do any of you have one you can copy for like $5 plus shipping. I am having a problem with the body I bought a new one and can't figure how to mount it. I bought parts from tower they say is body mounts but it is a pipe and some other parts. I don't use it because I ant figure it out realy havent taken the time. or that bolink body you were talking about what body is it and is it just the bolink body posts. Mainly my problem is getting the battery in and the cab on.

    Oh and no i did not get that email sorry
    Thanks for the help.

    Frank
     

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •