Notices
 

Thread: Paint problems

Results 1 to 6 of 6
  1. Question Paint problems 
    #1
    Join Date
    03-06-2016
    Location
    Story City, Ia. US
    Posts
    1
    I have been painting Lexan bodies for over 25 year without problem. Recently, however, I am having problems with the paint sticking to the cars. The paint is just flaking off with just a tap on the body. The only thing I have changed about my technique is I am using 3 brands of paint to achieve the look I want. I am using Patra, Tamiya and Duratrax. Are these paints compatable with each other, or is something else going on?
     

  2.  
    #2
    Join Date
    12-04-2012
    Location
    Trenton,Michigan.USA
    Posts
    804
    its your mixing of brnds ..I only use House of Kolors ..
     

  3.  
    #3
    Join Date
    05-26-2016
    Location
    Toronto
    Posts
    20
    Last edited by Ilyn_C; 05-27-2016 at 12:31 AM. Reason: typo
    "They may be toy cars, but I spend REAL money to race them!"
     

  4.  
    #4
    Join Date
    06-02-2016
    Location
    Bhopal, MP, India
    Posts
    10
    That is good video and solve your problem.
     

  5.  
    #5
    Join Date
    01-09-2002
    Location
    Temple, TX
    Posts
    3,848
    Seems to me it's like almost everything else, nothing is made like it used to be. But if your using the same paint as all the years before, I'd say it's something different in the making of the bodies.
    Do, or do not. There is no try!
     

  6.  
    #6
    Join Date
    01-07-2017
    Location
    America
    Posts
    1
    Feel sad for you
     

Tags for this Thread

View Tag Cloud

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •